pubspec_extract 2.0.5 copy "pubspec_extract: ^2.0.5" to clipboard
pubspec_extract: ^2.0.5 copied to clipboard

Extracts Dart pubspec.yaml file and generate pubspec.dart at build time

14
likes
140/ 140
pub points
61%
popularity

We analyzed this package 5 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 9 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: builder, builder.MyBuilder, builder.MyBuilder.MyBuilder, builder.MyBuilder.options, builder.pubspecBuilder.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.5.0 2.5.0
build ^2.0.0 2.4.1 2.4.1
dart_style ^2.0.0 2.3.6 2.3.6
logging ^1.0.0 1.2.0 1.2.0
path ^1.8.0 1.9.0 1.9.0
pub_semver ^2.1.0 2.1.4 2.1.4
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
meta - 1.14.0 1.14.0
package_config - 2.1.0 2.1.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

14
likes
140
pub points
61%
popularity

Publisher

verified publishernfet.net

Extracts Dart pubspec.yaml file and generate pubspec.dart at build time

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

args, build, dart_style, logging, path, pub_semver, yaml

More

Packages that depend on pubspec_extract