sentry_flutter 7.16.1 copy "sentry_flutter: ^7.16.1" to clipboard
sentry_flutter: ^7.16.1 copied to clipboard

Sentry SDK for Flutter. This package aims to support different Flutter targets by relying on the many platforms supported by Sentry with native SDKs.

749
likes
140/ 140
pub points
99%
popularity

We analyzed this package 31 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

733 out of 1097 API elements (66.8 %) have documentation comments.

Some symbols that are missing documentation: sentry_flutter.AdditionalInfoExtractor, sentry_flutter.Breadcrumb.Breadcrumb.console, sentry_flutter.Breadcrumb.copyWith, sentry_flutter.Breadcrumb.Breadcrumb.http, sentry_flutter.Breadcrumb.Breadcrumb.userInteraction.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:sentry_flutter/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/integrations/integrations.dart that imports:
  • package:sentry_flutter/src/integrations/load_release_integration.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:sentry_flutter/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/integrations/integrations.dart that imports:
  • package:sentry_flutter/src/integrations/load_release_integration.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:sentry_flutter/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/integrations/integrations.dart that imports:
  • package:sentry_flutter/src/integrations/load_release_integration.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:sentry_flutter/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/integrations/integrations.dart that imports:
  • package:sentry_flutter/src/integrations/load_release_integration.dart that imports:
  • package:package_info_plus/package_info_plus.dart that imports:
  • package:package_info_plus/src/package_info_plus_windows.dart that imports:
  • package:package_info_plus/src/file_version_info.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package not compatible with platform Web

Because:

  • package:sentry_flutter/sentry_flutter.dart that imports:
  • package:sentry_flutter/src/integrations/on_error_integration.dart that imports:
  • package:sentry_flutter/src/sentry_flutter_options.dart that imports:
  • package:sentry_flutter/src/event_processor/screenshot_event_processor.dart that imports:
  • package:sentry/sentry.dart that imports:
  • package:sentry/src/type_check_hint.dart that imports:
  • package:sentry/src/http_client/failed_request_client.dart that imports:
  • package:sentry/src/http_client/sentry_http_client.dart that imports:
  • package:sentry/src/http_client/breadcrumb_client.dart that imports:
  • package:sentry/src/hub_adapter.dart that imports:
  • package:sentry/src/sentry_client.dart that imports:
  • package:sentry/src/transport/spotlight_http_transport.dart that imports:
  • package:sentry/src/utils/transport_utils.dart that imports:
  • package:sentry/sentry_io.dart that imports:
  • package:sentry/src/sentry_isolate.dart that imports:
  • dart:isolate
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.0 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
meta ^1.3.0 1.11.0 1.12.0
package_info_plus >=1.0.0 <=5.0.1 4.2.0 5.0.1
sentry 7.16.1 7.16.1 7.16.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
package_info_plus_platform_interface - 2.0.1 2.0.1
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.3.3 4.3.3
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

749
likes
140
pub points
99%
popularity

Publisher

verified publishersentry.io

Sentry SDK for Flutter. This package aims to support different Flutter targets by relying on the many platforms supported by Sentry with native SDKs.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

Documentation
API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter, flutter_web_plugins, meta, package_info_plus, sentry

More

Packages that depend on sentry_flutter