geolocator_android 4.5.2 copy "geolocator_android: ^4.5.2" to clipboard
geolocator_android: ^4.5.2 copied to clipboard

PlatformAndroid
unlisted

Geolocation plugin for Flutter. This plugin provides the Android implementation for the geolocator.

5
likes
130/ 140
pub points
98%
popularity

We analyzed this package 3 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

98 out of 99 API elements (99.0 %) have documentation comments.

Some symbols that are missing documentation: geolocator_android.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
geolocator_platform_interface ^4.1.0 4.2.2 4.2.2
meta ^1.10.0 1.11.0 1.12.0
uuid ^4.1.0 4.3.3 4.3.3
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.8.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
sprintf - 7.0.0 7.0.0
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

5
likes
130
pub points
98%
popularity

Publisher

verified publisherbaseflow.com

Geolocation plugin for Flutter. This plugin provides the Android implementation for the geolocator.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, geolocator_platform_interface, meta, uuid

More

Packages that depend on geolocator_android